Les bugs de macOS Mojave et Xcode 10

PyrohPyroh Membre

Bonjour à tous,

TL|DR: J'ai des bug dans Mojave et comme je n'arrive pas en trouver trace sur le net je me demande si c'est pas mon Install qui est pourrie.

Je suis sûr que comme moi certains ici utilise la dernière beta de macOS.
J'ai des bug plus ou moins gênant depuis la beta 4 qui persistent encore avec la 6 sortie hier.

Pour commencer au niveau du système en lui même j'ai un soucis avec le rendu de certains champs de recherche. Ceux qui me paraissent être des sous-classes de NSSearchField du moins. J'ai testé dans une app avec un NSSearchField standard pas de soucis.
Voilà ce que ça donne :

Dans Xcode :


Dans Dash:

Dans Word:

J'ai également un autre bug dans Xcode depuis la beta 4. Quand je suis dans une playground et que j'édite le code Xcode va planter de manière impromptue. Surtout quand je choisi une entrée d'auto-complétion. Un Xcode ouvert sur une playground ne vit pas plus de 2 minutes chez moi si on édite le code qu'il contient.

Bref, je n'ai rien trouvé sur le net reprenant ces deux soucis, j'ai tenté Reddit et twitter mais j'ai fait chou blanc. Les gens sont pourtant prompts à se plaindre en règle générale... Est-ce qu'un de vous à aussi ces soucis et il est intéressant de faire un radar ou est-ce que je suis le seul et qu'il est intéressant de faire une clean Install ?

«1

Réponses

  • DrakenDraken Membre

    Je suis sûr que comme moi certains ici utilise la dernière beta de macOS.

    Pas chez moi, désolé ..

  • @Pyroh a dit :
    Bonjour à tous,

    TL|DR: J'ai des bug dans Mojave et comme je n'arrive pas en trouver trace sur le net je me demande si c'est pas mon Install qui est pourrie.

    Je suis sûr que comme moi certains ici utilise la dernière beta de macOS.
    J'ai des bug plus ou moins gênant depuis la beta 4 qui persistent encore avec la 6 sortie hier.

    Pour commencer au niveau du système en lui même j'ai un soucis avec le rendu de certains champs de recherche. Ceux qui me paraissent être des sous-classes de NSSearchField du moins. J'ai testé dans une app avec un NSSearchField standard pas de soucis.
    Voilà ce que ça donne :

    Dans Xcode :


    Dans Dash:

    Dans Word:

    J'ai également un autre bug dans Xcode depuis la beta 4. Quand je suis dans une playground et que j'édite le code Xcode va planter de manière impromptue. Surtout quand je choisi une entrée d'auto-complétion. Un Xcode ouvert sur une playground ne vit pas plus de 2 minutes chez moi si on édite le code qu'il contient.

    Bref, je n'ai rien trouvé sur le net reprenant ces deux soucis, j'ai tenté Reddit et twitter mais j'ai fait chou blanc. Les gens sont pourtant prompts à se plaindre en règle générale... Est-ce qu'un de vous à aussi ces soucis et il est intéressant de faire un radar ou est-ce que je suis le seul et qu'il est intéressant de faire une clean Install ?

    Hello,
    Je confirme le bug pour le NSSearchField

  • PyrohPyroh Membre

    Merci pour vos retours 😃
    Je vais réfléchir à l'éventualité de faire un radar.

  • MagiicMagiic Membre

    Pas remarqué ces bugs de mon coté.

    J'ai davantage de bugs sur iOS que Mojave paradoxalement alors que la première bêta sur iOS était très stable.

  • PyrohPyroh Membre

    @Magiic a dit :
    Pas remarqué ces bugs de mon coté.

    Ah ouais même pas sur NSSearchField ?

  • Chez moi en bêta 5 en HighSierra, le playground n'affiche pas les résultats et lance le ventila a fond et assez vite même ????

  • DrakenDraken Membre

    @Gercofis a dit :
    Chez moi en bêta 5 en HighSierra, le playground n'affiche pas les résultats et lance le ventila a fond et assez vite même ????

    Jamais utilisé ce truc (le playgroud). Pour le reste, Xcode 10 bêta 5 se comporte normalement sur mon MBPr 13" 2015.

  • Qu'est-ce qui t'empêches de regarder ?

  • @Gercofis a dit :
    Qu'est-ce qui t'empêches de regarder ?

    J'ai testé un jour avec le template Game, sensé faire du SpriteKit. C'est n'importe quoi ! Je n'ai même pas réussi à afficher l'image de l'écran ..

    Je comprend l'utilisation de ce truc pour des programmes simplistes du genre "a=12, b=20, c = a+b", mais je n'en comprend pas l'intérêt pour une application un peu évoluée avec une interface graphique.

    Pour te faire plaisir, j'essaye depuis une heure de faire tourner le template UIKIt avec le playground. Cela fonctionne, mais je n'arrive toujours pas à voir le résultat sur l'écran. Enfin pas grave, je regarde une vidéo sur Netflix en même temps : Mr. Sunshine, une nouvelle série coréenne absolument fabuleuse. Cela ne déclenche absolument pas le ventilateur, malgré une heure de tests ..

    MacOS 10.13.06

  • on se comprend mal je parle de la version Xcode 10 Béta et playground est cessé présenter un résultat a chaque fois que c'est possible et print affiche dans la console, c'est ce qui ne marche pas chez moi...

  • Mais si on se comprend. J'ai testé playground avec Xcode 10 bêta 5 pendant une heure, avec une vidéo en tâche de fond, pour charger la barque (et m'aider à passer le temps). Le ventilateur ne s'est JAMAIS déclenché.

    J'ai pris ce template playground :

    Qui donne ceci à l'exécution :

    J'ai finalement compris qu'il faut cliquer sur le petit carré à l'extrémité droite d'une ligne de code pour visualiser son effet graphique.

    Mesurée avec le moniteur d'activité, la charge processeur de ce test varie entre 1% et 2%. Pas étonnant que le ventilateur ne se déclenche pas ..

  • GercofisGercofis Membre
    11 août modifié #13

    Chez moi je n'ai rien ni a droite, ni en bas dans la console quand je fais un print, quand au ventilateur il se met en route de suite, le problème est bien chez moi et que chez moi.
    Le même playground fonctionne sur la version en cours...
    J'ajoute que ça semble assez utile pour tester "guard", "if let","??" avec lesquelles j'ai du mal a me familiariser...

  • @Gercofis a dit :
    J'ajoute que ça semble assez utile pour tester "guard", "if let","??" avec lesquelles j'ai du mal a me familiariser...

    Tu as encore des problèmes avec les optionals ? Moi j'aurais du mal à me passer d'eux, maintenant. Après des débuts un peu difficile, il est vrai..

  • GercofisGercofis Membre
    11 août modifié #15

    Ben les optionals pas vraiment, mais c'est vrai que l'utilisation de ces tests servent bien souvent a ça...
    Disons que l'utilisation n'est pas intuitive encore pour moi, comme les closures d'ailleurs.
    J'ai pris les derniers cours de Matthieu avec Xcode 10.5 bêta et je suis dans la une section Playground, c'est une révision a ce stade qui n'apporte pas grand chose, je ne fais pas les exercices et même parfois j'écoute simplement en arrière plan...
    Mais tout de même depuis les premières vidéos Codabee je navigue beaucoup mieux dans Xcode et IOs, mais vraiment mieux, Matthieu est quand même assez nickel, il répond tout le temps aux questions, j'avoue avoir du mal comprendre comment il trouve le temps de faire tout ?

    PS: Evidemment qu'utiliser Playground pour de l'interface, c'est pas top plutôt tester un algorithme a la volé

  • @Gercofis a dit :
    je ne fais pas les exercices

    Tu sera maudis pendant 1 000 générations ..

  • Précisions quand même je ne fais pas les exercices sur les choses basiques, déjà vues, les autres je les fais et Matthieu s'arrange toujours pour coller un truc un peu compliqué justement...

  • Il est récent ce cours ? J'ai acheté le précédent de Matthieu sur Xcode 9 et iOS 11, quand il était à 12 euros. mais je n'avais pas vu celui-ci, qui est à presque 200 euros d'ailleurs..

    Enfin tous les cours d'udemy sont dans les 200 euros, avec des promotions occasionnelles à 10-12 euros. Tu t'as payé combien ?

    Précisions quand même je ne fais pas les exercices sur les choses basiques, déjà vues, les autres je les fais

    Ah d'accord, ce sera seulement une malédiction pour 200 générations, donc ..

  • 9€ j'ai reçu les promos et quand je regarde maintenant c'est de l'ordre de 14€, je peux tenter de lui demander la même promo... En plus maintenant je le connais bien il répond toujours a toutes les questions et tout et tout....
    Au demeurant je n'ai pas l'impression que Swift 4.2 apporte beaucoup de chose, pour l'instant je n'ai pas vu de nouveauté hormis celle du playground qui chez moi marche moyennement...

  • DrakenDraken Membre
    11 août modifié #20

    Sur mon compte Udemy le cours est en promotion à .. 179 € !
    Je viens de faire une copie d'écran :

    Au demeurant je n'ai pas l'impression que Swift 4.2 apporte beaucoup de chose, pour l'instant je n'ai pas vu de nouveauté

    Moi j'ai été amusé de voir la nouvelle manière de générer des nombres aléatoires, absolument identique à celle que j'utilise depuis deux ans.

    Apple avait prévenu que le code 4.2 serait compatible avec le code 3.0. Les grosses évolutions syntaxiques du langage ont eu lieu lors du passage des versions 2.0 et 3.0. Les évolutions sont surtout internes, à l'intérieur du compilateur.

  • GercofisGercofis Membre
    12 août modifié #21

    Je viens de voir que je peux te l'offrir a 19,99 € ?
    peut-être j'ai ce prix là parce que j'en ai déjà 4 au total, je sais pas.
    En tout cas si le Language ne change pas trop ce n'est pas plus mal.
    Chez moi avec les 2 versions sur High Sierra ça bloque au niveau des simulateurs qui devient inaccessible avec Xcode en cours et bloque sur Xcode Béta a l'installation du coup plus de simulateur

  • @Gercofis a dit :

    Chez moi avec les 2 versions sur High Sierra ça bloque au niveau des simulateurs qui devient inaccessible avec Xcode en cours et bloque sur Xcode Béta a l'installation du coup plus de simulateur

    Attend la sortie officielle d'XCode 10. Cela ne devrais plus tarder; d'ici un ou deux mois.

  • Matthieu dit fin septembre et en plus vu mes problèmes avec ?

  • Xcode 9 fonctionne correctement chez toi, non ?

  • Xcode 9 fonctionne correctement avec High Sierra sauf le Drag and Drop dans l'éditeur.
    Par contre avec Xcode 10 il y a un conflit avec les simulateurs qui refusent de se lancer je vais donc le virer d'autant qu'il n'y a pas de nouveautés transcendantes.

  • DrakenDraken Membre
    12 août modifié #26

    Je viens d'avoir une idée sur ton problème de simulateur. Je viens de remarquer que l'affichage des graphismes est assez lent sur les simulateurs d'Xcode 10.

    Il y avais le même problème sur certains simulateurs d'Xcode 9 bêta. N'ayant pas finalisé la simulation hard des fonctions graphiques iOS pour toutes les cartes vidéos, les ingénieurs d'Apple faisant tourner les simulateurs avec une version LOGICIELLE des fonctions graphiques, ce qui forçait le processeur à carburer à mort.

    Cela a été réglé à la sortie officielle d'xCode 9, sauf pour le simulateur d'iPhone X qui a ramé un certain temps, avant de tourner normalement quelques semaines après, grâce à une mise à jour.

    Ton MBP date de quelle année ? De quel type de carte graphique est-il équipé ?

  • @Pyroh a dit :

    @Magiic a dit :
    Pas remarqué ces bugs de mon coté.

    Ah ouais même pas sur NSSearchField ?

    Pas remarqué jusqu'ici en tout cas. Je viens tout juste d'installer la nouvelle MAJ de Mojave peut-être que ça corrige les problèmes que tu soulevais.

  • @Magiic a dit :

    Pas remarqué jusqu'ici en tout cas. Je viens tout juste d'installer la nouvelle MAJ de Mojave peut-être que ça corrige les problèmes que tu soulevais.

    Le D&D ? problème playground une fois installé sur la Béta 10 ne fonctionne plus sur la 9 !!!

  • Les miracles peuvent arriver, comme par magie les 2 Playgrounds cohabitent a ma grande surprise...
    Je pense mais ça n'engage que moi qu'un téléchargement devait être en cours...
    Pour le D&D de l'éditeur de code rien de neuf... Marche toujours pas...
    Et je ne crois pas a un changement coté Apple...

  • Qu'est ce que tu appelles D&D ?

    Pour l'instant pas de soucis majeur à noter de mon coté sur Xcode ou plus globalement sur Mojave.

  • Drag And Drop

Connectez-vous ou Inscrivez-vous pour répondre.