Invalid sdk value

Salut,

J'essaie d'envoyer une nouvelle version de mon app compilée avec Xcode 10.2 (qui est la version officielle sur l'AppStore, et non une version beta depuis lundi soir).

L'AppStore a rejeté mon binaire:

Invalid sdk value - The value provided for the sdk portion of LC_VERSION_MIN_IPHONEOS in your app is 12.2 which is greater than the maximum allowed value of 12.1.

Please correct the following issues, then upload again.

Qu'ai-je loupé ? Bug Apple ?
Xcode 10.2 est la version officielle il me semble, iOS 12.2 est sorti lui aussi lundi soir...

Réponses

  • DrakenDraken Membre
    26 mars modifié #2

    Un lutin qui n'a pas lu la note de service sur Xcode 10.2 ?

    Pour ma part, je n'arrive pas à installer la mise à jour d'Xcode 10.2. Je n'ai plus que 11 Go de libre sur mon SDD de 128 Go, ce qui n'est manifestement pas suffisant.

    C'est fou, comment Android Studio s'étale sur le disque. Il m'a squatté presque 35 Go sur le SSD .. Il est temps que je transfére Kotlin et compagnie sur un PC, avec un gros SDD. Cela libérera le p'ov SSD de mon MBPr 2015 ..

  • muqaddarmuqaddar Administrateur

    Bon, je vais faire un clean, et prier alors.

  • muqaddarmuqaddar Administrateur

    Après installation de macOS 10.14.4, ça a marché...

  • CéroceCéroce Membre, Modérateur

    On ne pouvait pas envoyer de build avec Xcode 10.2 hier.
    Il est habituel de ne pas pouvoir soumettre des archives avec les versions bêta de Xcode.
    Mais Apple avait oublié d'autoriser Xcode 10.2 sur le serveur d'AppStoreConnect. Ce n'est pas la première fois que ça arrive.

Connectez-vous ou Inscrivez-vous pour répondre.