Alors, qu'avez vous pensé de la WWDC 2021 ?

TofTof Membre
16 juin modifié dans Coin canapé & détente #1

Qu'avez vous pensez du WWDC de 2021 ?
Perso j'ai regardé la vidéo sur async/await et toutes celles qui tournent au tour. J'ai trouvé ça intéressant. Bon comme d'habitude c'est pas avec des présentations d' 1/2 heures voire même d'un peu plus 1h des vidéos du WWDC qui vont permettre de bien maitriser les sujets traités mais ça donne un aperçu.
Avec Swift 5.5 Apple a fait un sacré boulot !!!
Pour SwiftUI 3 les évolutions sont aussi les bienvenues. Mais à mon gout elles auraient du être déjà là avec SwiftUI 2.
Y a par contre un souci avec SwiftUI c'est que comme d'habitude il faudra attendre que iOS 15 soit sur 98% des devices pour envisager de passer les applications existantes sur SwiftUI 3.
Ce qui est dommage c'est qu'Apple n'a pas mise en place une couche de retro-compatiblité afin qu'on puisse écrire les apps en SwiftUI 3 et qui grâce à cette couche marcheraient sur des devices qui n'ont que SwiftUI 1 ou SwiftUI 2.
Un dev Android me disait que c'est ce que Google avait fait de leur coté, enfin si j'ai bien compris.
Autre point que j'ai trouvé intéressant c'est SwiftPM avec le support par Xcode 13 de "Package Collection". SwiftPM évolue dans le bon sens. Perso tous mes projets sont tous sur SwiftPM depuis un moment déjà. CocoaPods et Carthage sont de l'histoire anciennes.
J'ai encore pas mal de vidéos à regarder donc y a sans doute des trucs intéressants que j'ai pas encore vu 😋

Mots clés:

Réponses

  • CéroceCéroce Membre, Modérateur

    @Tof a dit :
    Y a par contre un souci avec SwiftUI c'est que comme d'habitude il faudra attendre que iOS 15 soit sur 98% des devices pour envisager de passer les applications existantes sur SwiftUI 3.
    Ce qui est dommage c'est qu'Apple n'a pas mise en place une couche de retro-compatiblité afin qu'on puisse écrire les apps en SwiftUI 3 et qui grâce à cette couche marcheraient sur des devices qui n'ont que SwiftUI 1 ou SwiftUI 2.

    iOS 15 est compatible avec tous les terminaux compatibles avec iOS 14 ou 13.
    Faire une couche de compatibilité n'est pas simple, il y a trop de différences de comportement de UIKit d'une version à l'autre. Aussi les ingés d'Apple ont décidé de faire reposer chaque version de SwiftUI sur une seule version de UIKit. D'ailleurs ça se voit dans les nouvelles API de UIKit qui correspondent aux nouveautés de SwiftUI (je pense en particulier aux Diffable Data Sources introduites l'an passé).

    Un dev Android me disait que c'est ce que Google avait fait de leur coté, enfin si j'ai bien compris.

    À la différence d'iOS, où chaque version d'une bibliothèque correspond à une version de l'OS, sur Android, on peut intégrer les bibliothèques dans l'appli. Ainsi on peut avoir Jetpack Compose et ses dépendances copiées dans l'appli. L'avantage est qu'on peut utiliser les nouvelles libs même sur de très vieux OS.
    Les inconvénients sont que ça augmente le poids des applications, et que ça n'incite pas les constructeurs à assurer la compatibilité de leurs anciens téléphones avec les nouveaux OS.

    Autre point que j'ai trouvé intéressant c'est SwiftPM avec le support par Xcode 13 de "Package Collection". SwiftPM évolue dans le bon sens. Perso tous mes projets sont tous sur SwiftPM depuis un moment déjà. CocoaPods et Carthage sont de l'histoire anciennes.

    Étant donné que notre projet est encore écrit à 60% en Objective-C, Cocoapods va encore nous servir quelques années! Mais enfin SwiftPM commence à se suffire à lui-même.

    J'ai encore pas mal de vidéos à regarder donc y a sans doute des trucs intéressants que j'ai pas encore vu 😋

    Je n'ai jamais réussi à regarder ne serait-ce que la moitié des vidéos ;-)

Connectez-vous ou Inscrivez-vous pour répondre.