Mettre un UIButton sur une vidéo

Bonjour à tous !

Désolé si ma question parait basique, mais là, je sèche totalement !

Pour mon application, j'utilise l'API Twilio. Cependant, j'ai absolument besoin d'un bouton raccrocher. Le problème est qu'il ne fonctionne pas...

Je l'ai créé avec le storyboard, et lorsque je clique dessus, il ne se passe rien. C'est exactement le même cas si je le créé programmatiquement.

Je tiens à préciser que Twilio utilise WebRTC.
Je tiens aussi à préciser que j'ai commenté la fonction qui appelle l'API, et donc, comme il n'y avait de de vidéo, le bouton a fonctionné correctement ! J'ai cherché, mais je ne parviens pas à comprendre ce qui ne va pas...

Je vous remercie pour votre aide !

Mots clés:

Réponses

  • LarmeLarme Membre
    25 nov. modifié #2

    Pourrais-tu regarder la View Hierarchy quand tu appuies dessus ?
    Histoire de savoir si la vue Twilio (car je suppose qu'il y a une vue vidéo) n'est pas par-dessus avec des zones transparentes ?
    Je ne connais pas Tiwlio, mais tu as sûrement une vue pour cette dernière, ils la fournissent ? Tu ajoutes ton bouton sur cette dernière ou sur la vue parente ?

  • Luc-ALuc-A Membre

    Merci Merci Larme !!

    J'ai effectivement cherché à afficher la hiérarchie, mais je ne savais plus comment faire...

    En fait, j'ai 3 vues imbriquées les unes dans les autres.
    Je ne sais pas comment faire pour utiliser la dernière vue comme un IBOutlet...
    Les vues sont implicites, je n'ai vraiment pas grand chose à faire pour utiliser Twilio, juste à appeler une fonction. Apparemment, tout est fait programmatiquement.

  • Luc-ALuc-A Membre

    Il m'arrive d'être bête, parfois !!

    Pour que le bouton fonctionne, il suffit juste de l'ajouter à la fin du chargement de l'API.
    Voilà qui est fait. Certes, j'ai créé le bouton programmatiquement, mais ça fonctionne !

    Merci Larme !!

Connectez-vous ou Inscrivez-vous pour répondre.