Qui a eu ça ?

Avec Xcode 10.1 et 10.2, à la compilation j'obtiens:
objc[1473]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff8d858210) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x10b766dc8). One of the two will be used. Which one is undefined.
Le projet compile sans erreur mais l'application ne permet pas de choisir un fichier, donc ne fonctionne pas.
J'ai vérifié qu'effectivement ces deux Frameworks sont présents dans /System/Library/PrivateFrameworks/ et je ne vois pas comment m'en sortir !!
Y a t-il une solution ?

Réponses

  • PyrohPyroh Membre

    J'ai déjà eu le message dans la console mais sans les conséquences. L'application ouvrait bien les fichiers choisis.
    T'es sûr de ton code relatif à cette partie de ton app ? Ça arrive de passer de certains trucs.

  • tabliertablier Membre

    Effectivement c'est quelque chose de connu ! les réponses sont du genre: Il n'y a rien à faire c'est un problème pour Apple.

  • klogklog Membre
    27 mars modifié #5

    J'imagine que tu n'as pas installé de framework (en provenance d'une autre version de SDK par exemple) ?

  • Essaye de vérifier l'intégrité des fichiers (genre md5)

  • PyrohPyroh Membre

    Tu utilise quel version du SDK macOS ? Tu peux tenter de voir si une autre version est impactée.

  • tabliertablier Membre

    Et non, je n'ai installé aucun framework. les seuls qui sont installés sont ceux livrés avec le système et ceux livrés avec Xcode. Ce problème est apparu hier sous Xcode 10.1. J'ai installé le 10.2, le problème est le même.

  • PyrohPyroh Membre

    Tu veux qu'on teste chez nous pour éloigner la thèse du problème local ?

  • DadderDadder Membre

    Je ne vois de problème en local, c'est plutôt question de version.

  • tabliertablier Membre

    J'ai fait une installation complète de mon HD après formattage et ça avait disparu ! Hier c'est revenu sous l'OS 10.14.5. J'ai un doute très fort sur les outils délivrés par Microchip (ide, compilateur, assembleur et debugger). Avec les outils Microchip j'ai plein de message du genre "l'assembleur MAPS doit être mis à jour, contactez le développeur". Ce ne sont pas les seuls programmes qui me donnent cette alerte et je ne sais quoi en penser.

  • PyrohPyroh Membre

    @tablier a dit :
    Ce ne sont pas les seuls programmes qui me donnent cette alerte et je ne sais quoi en penser.

    Qu'il faut mettre l'assembleur MAPS à jour ?

  • tabliertablier Membre
    3 juin modifié #13

    Ouais, mais j'ai beau charger les dernière versions, elles ne sont toujours pas à jour !!!! D'ici que j'abandonne le Mac pour Linux ou PC (beurk!) au moins pour les outis Microchip, il n'y a pas loin. Et par ailleurs je ne suis pas sur que ça soit la source de mes ennuis !!!

  • PyrohPyroh Membre

    Contacte le développeur ?

  • tabliertablier Membre
    5 juin modifié #15

    J'ai à demi solutionné mon problème ! J'ai repassé tous les fichiers sur mon ancien MBPro, sous 10.11 et Xcode 8.x. A la compilation la première erreur qui sort, ce n'est pas celle citée plus haut, mais le manque de la classe webView ! Je rajoute le webKit dans le projet et oh merveille ça compile et ça fonctionne ! L'erreur citée plus haut sort toujours dans la console de Xcode mais n'empêche rien. Je suis repassé sous 10.14.5 et l'ajout du webKit donne les mêmes résultat que sous 10.11 ! Curieux que Xcode 10.2 ne donne pas en premier la même erreur que Xcode 8.x !!

Connectez-vous ou Inscrivez-vous pour répondre.