compte de dév gratuit et installation d'apps sur son propre matos

Bonjour à toutes et à tous.
Depuis début 2016, j'utilise un compte de dev gratuit pour installer mes propres apps sur mon propre iPhone. Depuis 3 ans et demi, chaque semaine, je recompile 2 de mes apps pour pouvoir les utiliser sur mon iPhone (dans XCode, touches cmd+R). Cela fonctionnait très bien mais ne fonctionne plus depuis début juillet. XCode affiche un message m'invitant à vérifier chaque app sur mon iPhone. Sur mon iPhone, la vérification échoue et iOS affiche un message prétextant un problème de réseau (connexion WiFi seule activée ou connexion 4G seule activée). Je viens de créer un nouveau compte de dév gratuit et le problème persiste à l'identique. Je suppute que les comptes de dev gratuit ne peuvent plus installer d'app sur leur propre matériel depuis début juillet, soit un mois après la dernière WWDC. Je suis en contact avec le support d'Apple mais pour le moment il ne m'a indiqué aucune piste permettant de résoudre ce problème. Une bonne âme aurait-elle des infos ? Merci de vos réponses.
NB : XCode 10.2.1, macOS 10.14.3 et iOS 12.3.1, applis en Objective-C.

Réponses

  • J'ai à peu près le même problème. Si tu as un retour, j'aimerais le connaitre, merci par avance.

  • PyrohPyroh Membre

    Chez moi ça marche™

  • heretheret Membre

    Donc, je suis mauvaise langue. :p
    D'où ce problème pourrait-il venir ?
    Pour l'internet fixe et pour le mobile, j'ai le même prestataire (la boîte d'un milliardaire en béton ...). Est-ce que ça pourrait venir de lui ? Je n'y crois pas mais bon.
    La dernière fois que ça a marché, c'était le 30 juin. Le premier échec c'était le 7 juillet. Entretemps,je n'ai touché à aucun paramètre concernant les apps perso ni côté XCode ni côté iOS, je le jure monsieur le juge.
    J'ai oublié de préciser que dans XCode, au niveau de "code signing", j'ai bien sûr activé la gestion automatique depuis longtemps.
    Le fait que j'ai exactement le même problème avec un compte de dév tout frais me laisse très perplexe puisque j'ai obtenu de tous nouveaux certificats sans lien avec ceux de l'autre compte.

  • DrakenDraken Membre

    @Pyroh a dit :
    Chez moi ça marche™

    Oui, mais t’as un compte développeur payant, non ?

  • PyrohPyroh Membre

    @Draken a dit :

    @Pyroh a dit :
    Chez moi ça marche™

    Oui, mais t’as un compte développeur payant, non ?

    Fichtre...

  • heretheret Membre

    Bon, les djeunz...
    J'ai eu des nouvelles du support Apple. Celui-ci me conseille une manip qui produit toujours ce message d'erreur concernant la connexion réseau. Rien de nouveau de ce côté là.

    Et il me demande aussi de vérifier si mon firewall n'empêcherait pas l'accès à https://ppq.apple.com, et là ...
    Essayé depuis le boulot (windows 8) ou de chez moi (macOS ou XUbuntu), Firefox, Chrome et Internet Explorer (au boulot seulement, hein >:) ) sont tous d'accord pour m'annoncer un pb avec le site et son certificat. Safari, version macOS et iOS, affiche une page toute blanche et le message "http/1.1 service unavailable".
    J'attends donc à nouveau le retour du support.

    Et chez vous, ça donne quoi l'accès à https://ppq.apple.com ?

    @Pyroh : quand tu écris que ça marche chez toi, as-tu régénéré le certificat qui sert à signer l'app ? Quand j'avais un compte payant ce certificat était valable plusieurs années si je me souviens bien. Avec un compte gratuit, celui qui sert à signer l'app n'est valable que pendant 7 jours. Le certificat lié au dév gratuit est valable plusieurs mois (1 an ou plus même).

  • Http/1.1 Service Unavailable

    Échec de la connexion sécurisée

    Une erreur est survenue pendant une connexion à ppq.apple.com. Le certificat contient une extension critique inconnue. Code d’erreur : SEC_ERROR_UNKNOWN_CRITICAL_EXTENSION

    La page que vous essayez de consulter ne peut pas être affichée car l’authenticité des données reçues ne peut être vérifiée.
    Veuillez contacter les propriétaires du site web pour les informer de ce problème.
    
  • heretheret Membre
    24 juil. modifié #9

    Merci Harlo, c'est exactement ce que j'ai chez moi et au boulot. De ce point de vue là, c'est rassurant :o

  • idem pour moi depuis ma maison dans le Vercors.

  • PyrohPyroh Membre

    @heret : J'ai effectivement un compte payant.
    Pour l'erreur HTTP j'ai la même.

  • klogklog Membre

    Pareil :

    Http/1.1 Service Unavailable

  • heretheret Membre

    ok, merci à tous.
    Yapuka attendre la réponse du support.

  • heretheret Membre

    Et la réponse du support est que j'ai un nouvel interlocuteur de niveau sénior qui m'a demandé de lui prouver à nouveau que mon iPhone et XCode communiquent bien, en USB/Lightning comme en wifi+ethernet.

  • PyrohPyroh Membre

    Ouais je vois...

  • heretheret Membre

    Oui, je pense aussi que c'est toujours au support de niveau 1. Ce sont des gens très sympathiques, mais qui ne savent pas comment ça marche et qui n'ont accès qu'à une base de connaissance dans laquelle ils font des recherches. Après la semaine caniculaire, week-end pluvieux annoncé, je devrais avoir le temps de rechercher dans les fichiers de logs sur mon hackintosh si XCode ne raconterait pas sa vie de manière détaillée et pertinente. Et si je ne trouve rien, j'espionnerai le trafic réseau entre mon matos et ppq.apple.com avec Wireshark ou un équivalent.

  • heretheret Membre

    Et voilà, c'est la fin, puisque je viens de mettre à jour mon iPhone en iOS 12.4 et le problème est résolu. Par contre, je regrette d'avoir mis à jour XCode en 10.3, puisque maintenant il y a des erreurs lors de la lecture de certains xib.

  • heretheret Membre

    @heret a dit :
    je regrette d'avoir mis à jour XCode en 10.3, puisque maintenant il y a des erreurs lors de la lecture de certains xib.

    Et quelques heures plus tard, plus d'erreur de lecture des vieux xib.
    Comme je dis souvent, l'informatique, quand ça marchera, on sera beaucoup moins nombreux ;)

  • Peut-on espérer un assouplissement en octobre 2019 ?

  • Peu probable

  • Que pense la communauté de Mojo ?
    mojo installer.org

  • PyrohPyroh Membre

    @Gercofis a dit :
    Que pense la communauté de Mojo ?
    mojo installer.org

    Tu n'as aucune certitude de ce que ce tool va faire et permettre sur ton device. D'instinct je m'en tiendrai éloigné...

  • heretheret Membre

    C'est trop drôle. J'avais laissé mon hackintosh en macOS 10.14.4 et je viens de le passer en macOS 10.14.6 pour pouvoir utiliser XCode 11. Et oui, XCode 11 réclame macOS 10.14.6 au minimum. Et si j'ai installé XCode 11, c'est en prévision de l'installation d'iOS 13 sur mon iPhone. Je n'ai pas encore installé iOS 13 sur mon iPhone (donc toujours en iOS 12. 4.1) et le problème de juillet se reproduit à l'identique, aux versions des OS et des outils près ! Bis repetita placent...

  • heretheret Membre

    iOS 13.1.1 installé sur l'iPhone et tout baigne à nouveau. Merci monsieur Apple de me mettre des bâtons dans les roues.

Connectez-vous ou Inscrivez-vous pour répondre.